Rose Colored Glasses

Random Thoughts on Instructional Design

Browser Requirements

The newest version of a browser will not always work well with campus-level software like Blackboard. Make sure you are using one of the supported versions listed below.

Windows 95, 98, ME & 2000

  • Netscape 4.77 and 7.0
  • Internet Explorer 5.0 , 5.5 and 6.0

Note: Many browser problems are caused by ad-blocking software. Software that disables pop-up windows and other Javascript functions also disables Blackboard tools. If you are running ad-blocking software or Internet Security bundles, please modify the software to allow pop-ups from the course management system URL.

Windows XP

  • Netscape 7.0
  • Internet Explorer 6.0
Macintosh OS 9.2
  • Netscape 4.77 and 7.0
  • Internet Explorer 5.1
Macintosh 0S X.1
  • Netscape 7
  • Internet Explorer 5.1 and 5.2
Macintosh 0S X.2
  • Netscape 7
  • Internet Explorer 5.2

Information

This entry was posted on April 11, 2006 by in Blackboard 8.
%d bloggers like this: